KALI 2016.1: Fixing A Damaged Repository

Fixing the KALI 2016.1 Repository

Fixing A Damaged Repository

After the installation and in some weird update cases, KALI Linux 2016.1 is running out of Sync – in terms of its repository. Here a short simple guidance how to fix this issue.
How the problem looks like? Here’s a simple example: You are trying to install a package with apt-get and get a strange error message like

E: Package 'xsltproc' has no installation candidate

Looks like this:

Here’s how to solve that problem!

First Step: Check the Repository

Open the file /etc/apt/sources.list by an editor of your choice. It should contain a line like that one:

deb http://http.kali.org/kali kali-rolling main non-free contrib

If you are missing this line: Add it. This will fix the missing repository issue immediately.

Second Step: Rebuild the Repository

After you fixed /etc/apt/sources.list, run the following commands:

apt-get update && apt-get upgrade

You are done. Now all apt-get based installations should work perfectly!

Fixing the KALI 2016.1 Repository

More About KALI Linux

Here are some cool books on KALI Linux. Quite a must have for every professional:

Kali Linux: Wireless Penetration Testing Beginner’s Guide

Basic Security Testing with Kali Linux 2

Learning Kali Linux: An Introduction to Penetration Testing

About Me

Since 16 years I offer my services as professional penetration tester to various customers all around the world. I offer simulated Advanced Persistent Treat (APT) attacks as well. Feel free to contact me for more details about my services.

 

 

Be the first to comment

Leave a Reply

Your email address will not be published.


*